How to downgrade Firefox to the last sane version (3.6)

So I keep ranting about Firefox here, and for good reason: the Mozilla team is going above and beyond the call of duty when it comes to driving users to other browsers.

However, try as I might, I simply encounter too many dealbreakers in Chromium.

When I think about it, the last version of Firefox that didn’t drive me crazy with crashing, incompatible add-ons, and stupid UI changes and features removed, it would have to be Firefox 3.6.

I keep forgetting how to do this, so I’m posting this here as much for my own reference as for anyone else’s. This is how to downgrade newer versions of Firefox to 3.6 and keep it that way, at least until things settle down a little, or until another browser comes along that can actually be a viable replacement for it — unlike newer versions of Firefox, sadly. This works with Mint 11, which means it will also work with Ubuntu 11.04.

Step 1: Edit /etc/apt/sources.list

This is a simple matter of editing a few files, ultimately. The first of which is sources.list. So, from a terminal, type this:

sudo nano /etc/apt/sources.list

Paste the following into there:

deb http://ftp.iinet.net.au/pub/ubuntu/ maverick main
deb http://ftp.iinet.net.au/pub/ubuntu/ maverick-updates main

Then hit ctrl+o to save it and ctrl+x to exit the file.

Step 2: Pin firefox and firefox-branding packages

Still from the terminal, type:

sudo nano /etc/apt/preferences.d/firefox

Paste the following into the file:

Package: firefox
Pin: release n=natty
Pin-Priority: -10

Package: firefox
Pin: release n=maverick
Pin-Priority: 900

Then hit ctrl+o to save it and ctrl+x to exit the file.

Then type:

sudo nano /etc/apt/preferences.d/firefox-branding

And paste the following into there:

Package: firefox-branding
Pin: release n=natty
Pin-Priority: -10

Package: firefox-branding
Pin: release n=maverick
Pin-Priority: 900

Then hit ctrl+o to save it and ctrl+x to exit the file.

Step 3: Update apt-get and install Firefox 3.6

Type this into your terminal window:

sudo apt-get update

This will refresh your packages list in apt.

Now do this so that you blow away the existing mess that is the current version of Firefox:

sudo apt-get remove firefox

And, finally, install Firefox 3.6:

sudo apt-get install firefox

And you’re done!

In my experience, this still gets updates as Mozilla pushes them out to 3.6.* installations (through the source you added in step 1), so as long as they’re still supporting Firefox 3.6, this will still be a viable option.

And I discovered that since I don’t need as many add-ons in Firefox 3.6 (I kept having to find more and more for later versions to deal with stupid things they kept breaking after Firefox 4), it actually starts up and seems to load webpages faster than the supposedly “new and improved” releases. So this is really more of an upgrade than a “downgrade”, but I didn’t want to confuse anyone.

Your mileage may vary, of course.

– Trent

About these ads

18 thoughts on “How to downgrade Firefox to the last sane version (3.6)

  1. Pingback: Links 1/10/2011: Linux Jobs, ACTA in Canada | Techrights
  2. Firefox 6 was the last straw for me with Ubuntu. Ubuntu doesn’t like playing with Fluxbox either, as you yourself have said several times.

    I installed Linux Mint Isadora Fluxbox edition, which has Firefox 3.6, and everything is now excellent.

  3. I have had to hunt down .deb packages as I am running Debian, but I completely agree with you Firefox 3.6 was the last nearly good release.

    Is there some kind of competition between the browser makers to see who can make the one that is the worst ?

    • It does seem to be that way, doesn’t it? It’s like we’ve gone into some bizarro world where browser devs are going down a list and saying “Okay, which are the things that would really piss people off the most? Okay, we’ll implement THOSE!” and bam, bam, bam. Unusable browser!

  4. which of the 2 should I paste paste, or both? Why was it written in different fonts? Baffled
    what would I have to write if I wanted ff3.0.19 ?
    do you have a crutch for tb2.0.0.24 ?

    Paste the following into the file:

    Package: firefox
    Pin: release n=natty
    Pin-Priority: -10

    Package: firefox
    Pin: release n=maverick
    Pin-Priority: 900

  5. Trent,
    ignore (delete) previous post.
    I followed your missive to the letter and it worked fine first time (Mint11). The relief is indescribable, THANK YOU! A decent extension manager again, user friendly and a damn site faster to boot. Been following ff progress, if that’s what you’d like to call it, with portable versions on xp all along, not much hope there, that’s for sure. I would have preferred 3.0, but hey, who’s quibbling.
    Any chance for a similar effort on tb2.0.0.24? Who needs tabs in a mailer?
    Thanks again, Le Bieque

    • I haven’t used Thunderbird in probably 2-ish years now, so I have no idea if something like this would work for it, but I’m sure someone out there does. People get pretty worked up over their favorite mail clients!

      I’m glad this helped at least with Firefox! Thanks for the comments!

      – Trent

    • I would like to have tabs in Thunderbird, and there is a perfectly valid reason I think has not been thought about me only:
      Sometimes (surprisingly often) I find myself in a situation where I’d like to keep the position I am in a mail I’m reading (a long one, ie. slashdot daily updates where I also want to see what link I have opened last) and yet read some other mail (maybe I just received something important or maybe for other reasons – I was actually surprised to see that IceDove (Debian brand of Thunderbird, I guess it’s still at 2.0 or whatever, but before tabs) and see that there actually was no tabs! I would have thought that the organization and development team behind it would had thought that years ago!

  6. I think 3.6 was the last of a generation whose linux native binaries actually run slower than windows’ firefox 3.6 running under wine. Perhaps that’s a better choice than downgrading. Barely as nonsensical, but with the advantage of “improved” performance.

  7. http://www.tuxradar.com/content/benchmarked-firefox-javascript-linux-and-windows-and-its-not-pretty

    The benchmark was on 3.0.6, but I think that things hadn’t changed much on 3.6. With 4 I think that there was a noticeable improvement in performance. From 4 to 7 it’s almost the same thing, I think they’re just in some “version number race”, whose actual numbers don’t mean much.

    I’m quite surprised with this post. Interface-wise it seems that one can easily enable the menu bar again, then it’s almost the same as 3.6, perhaps only differing in that the address bar is located below the tab, which isn’t something anyone should be bothered about. And speaking of “pure” browser, it has only improved, at least in my experience. I’ve also not have many “orphaned” extensions, which I think may be the biggest real problem. It actually crashes way less than 3.6. But perhaps that’s because I’m mostly actually using iceweasel, and its patches are preventing that? I’m not sure, I also have firefox 7 in parallel, and it’s not that different I think.

    BTW, other alternative would have 3.6 only in $HOME/.opt or something, much easier I think. Then one can use 3.6 with whatever does not work on 7 but also try to get used to the ever changing software versions every now and then. This is linux, for God’s sake, not windows where people still use IE 6, goddammit.

  8. could you please tell me why on earth you go back to 3.6? but his time please be more specific. which incompatible add ons ? starting time ? how many times a day you close your browser? performance was improved with EVERY version since 4.0!

  9. Let me try. At some point I suddenly realized that the bulk of my addons and time and effort was to get Ff back to what it was before every new version. Also MrTech Toolkit is important to me and with 4 no longer working. It was then that I resolved not to bother any longer. I like what I’ve got and I don’t like what I’m getting. Hey, I’m the customer after all, and not some corporate human resource on security steroids towing the line. 3.0.* is lightweight, has half the Mem Usage, and, to boot, without growing to gargantuan size after extensive usage, nor can I remember it ever freezing on me, unlike this new stuff. Performance improvement? not in my book, and not for a want of trying either! Peace

  10. 3.6 is great, I use it too, but aside from using SwiftFox I have also Debians IceWeasel instealled – they have kept with 3.6 series and it’s a good choice in ubuntu to download the lateste IceWeasel from http://packages.debian.org/ instead as it’s been kept up to date – yes, Mozilla still maintains it and they state on their page that since v. 5 the only older version they provide updates (for security and stability) is 3.6.

    If you download the old Ubuntu version you will get a version that has several since discovered security flaws – However I should think that the debian package would install just fine for Ubuntu, and the only difference between FireFox and IceWeasel is that it’s logo and name are changed so that according to MPL license of Mozilla they can release a modified version that is GPL’d – for those who care, this is another benefit of getting IceWeasel.

    Also what I’m creating is my own derivatives of IceWeasel 3.6 AND the latest FireFox patched and compiled for optimization just like SwiftFox, but with GPL license, optimizations for not only those platforms that SwiftFox was separately optimized in past (ie. AMD and Intel4 used to be separately available, unlike now (Older AMD and Intel links point to same 686 version) but also for very old machines, ie. 486′s.
    And not only versions optimized for speed – especially those after 486 or regular Pentium optimized versions there will be versions optimized for speed without compiler parameters that increase size and/or memory use otherwise (as well as default settings, which are, according to version, optimized SwiftFox like of to use as little memory as possible).

    So there will be different versions: “for speed”, “speed without extra memory consumption and size” and even “optimize for memory if at cost of speed even” versions, and compilations from 486 & Pentium to Pentium MMX, P2-4, Pentiums and AMD’s separately for all versions and the Swiftfox 64-bit in 32-bit OS and 64-bit OS versions.

    Follow my blog, I’m not sure how long it will take to get first version, but I’m hoping that the 1st version would be released in January or February 2012 – at least IceWeasel 3.6 based, after which the creation of derivative from latest FF should not take long.

    This will not be just *swift*, this will be optimized for the users machine – and unlike SwiftFox, which hasn’t updated for long time, will be kept up-to-date, and sources for compiling any version will be available as GPL – I might also include a FasterFox-like settings (not that plugin) to alter FF settings that according to patch files on SwiftFox site are actually the only modifications to the source code the SwiftFox has – and like FasterFox plugin it will offer presets, so you can get a memory optimized version for your old Pentium MMX 266Mhz but select a preset that instead of saving memory will speed up your page loads.

    This is the first place I have written about this – I will soon announce this plan on my own blog.

  11. You should specify that this is for Mint or shitbuntu. Saying it’s for linux in the general term implies that it’s useful for a real linux distribution. Not a “sudo apt-get” fix-all dummy distro.

    I can’t agree more that Mozilla is screwing up bad though. I’ll be in this small group of people who will refuse to upgrade for a lonnng time. Probably never. My favorite addons aren’t even compatible with FF4, which comes stock with slackware 13.37. Such a shame, it was my favorite browser since version .8.

    I recommend you switch to a better distro btw. Why use a ‘sane’ version of FF on an insane flavor of linux? Silly.

  12. @Theo
    Are you talking to author of the blog or me (message above yours)? I believe I was talking about Debian (which has the original apt system without flawed non-rolling upgrades) and I think it’s the best thing since sliced bread – and the article clearly mentions Ubuntu and that 2nd Debian-based system derived from Ubuntu…

  13. I stuck with 3.6.28 until recently, when I tried 12.1. Slowest browser ever. I experimented with IE9 and Chrome then went back to FF 3. Everything works

  14. I’ve done this before and got it to work. I tried it again now after a new mint11 installation and, although it went through all the motions, downloading, installing etc., I ended up with Firefox 15 again.

    Problem is, I’m thinking windows and for the life of me can’t figure out the Linux file structure. Searching with nautilus, I can’t even find the profile folder (yes, show hidden files and all).

    Would “mark for complete removal” help? Reluctant, as that would leave me without browser and no idea how to get it back. I know, if you can’t ride the bike, don’t get on. But one’s got to start somewhere! Any brief helpful suggestions? Time permitting of course.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s